summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2013-07-13 16:35:49 +0200
committerGravatar Martin Szulecki2013-07-13 16:35:49 +0200
commitb8169cbeda3699f3c0159267815cf9a011149950 (patch)
treee874619d08079da3c5b1889302f786671de381bf /configure.ac
parenta2ddca0916ef776dbd0c6304ea36b4ca7a35302c (diff)
downloadlibimobiledevice-b8169cbeda3699f3c0159267815cf9a011149950.tar.gz
libimobiledevice-b8169cbeda3699f3c0159267815cf9a011149950.tar.bz2
configure.ac: Simply check for asprintf and vasprintf
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 1 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 57cd233..a0b038e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -44,16 +44,7 @@ AC_TYPE_UINT32_T
AC_TYPE_UINT8_T
# Checks for library functions.
-AC_CHECK_FUNCS([strcasecmp strdup strerror strndup])
-
-AC_CHECK_FUNC(asprintf, [have_asprintf="yes"], [have_asprintf="no"])
-if test "x$have_asprintf" = "xyes"; then
- AC_DEFINE(HAVE_ASPRINTF,1,[define if asprintf is available])
-fi
-AC_CHECK_FUNC(vasprintf, [have_vasprintf="yes"], [have_vasprintf="no"])
-if test "x$have_vasprintf" = "xyes"; then
- AC_DEFINE(HAVE_VASPRINTF,1,[define if vasprintf is available])
-fi
+AC_CHECK_FUNCS([asprintf strcasecmp strdup strerror strndup stpcpy vasprintf])
AC_CHECK_HEADER(endian.h, [ac_cv_have_endian_h="yes"], [ac_cv_have_endian_h="no"])
if test "x$ac_cv_have_endian_h" = "xno"; then