summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Jonathan Beck2009-01-13 18:57:52 +0100
committerGravatar Jonathan Beck2009-01-13 18:57:52 +0100
commitd4694679f918750e920a2238d891cd2fbb741a90 (patch)
treeea52b9d253993b31ec71cbad35280d7c5eeab957 /configure.ac
parent564aebf941f2f0c5fb57d2f86091b37d6331b9d9 (diff)
downloadlibimobiledevice-d4694679f918750e920a2238d891cd2fbb741a90.tar.gz
libimobiledevice-d4694679f918750e920a2238d891cd2fbb741a90.tar.bz2
Add parts of a python binding to libiphone that also include libplist (using SWIG).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9516ec4..87ed8dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6,9 +6,15 @@ AC_INIT(libiphone, 0.1.0, nospam@nowhere.com)
AM_INIT_AUTOMAKE(libiphone, 0.1.0)
AC_CONFIG_SRCDIR([src/])
AC_CONFIG_HEADER([config.h])
+AC_CONFIG_MACRO_DIR([m4])
AC_PROG_LIBTOOL
+AM_PATH_PYTHON(2.3)
+AC_PROG_SWIG(1.3.21)
+SWIG_PYTHON
+
+
# Checks for programs.
AC_PROG_CC
AM_PROG_CC_C_O
@@ -60,4 +66,4 @@ if test "$no_debug_code" = true; then
AC_DEFINE(STRIP_DEBUG_CODE,1,[Strip debug reporting code])
fi
-AC_OUTPUT(Makefile src/Makefile include/Makefile fdi/Makefile dev/Makefile libiphone-1.0.pc)
+AC_OUTPUT(Makefile src/Makefile include/Makefile fdi/Makefile dev/Makefile swig/Makefile libiphone-1.0.pc)