summaryrefslogtreecommitdiffstats
path: root/swig/Makefile.am
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2012-03-21 21:29:53 +0100
committerGravatar Martin Szulecki2012-03-21 21:29:53 +0100
commitef69484cd678ede814ebc5d46bf84969b8d96051 (patch)
treecb37296120c3fd4a3faaf73124900ba513152bf2 /swig/Makefile.am
parentf41681ed6c7e7215390956d8beb51e6cd929c62a (diff)
downloadlibimobiledevice-ef69484cd678ede814ebc5d46bf84969b8d96051.tar.gz
libimobiledevice-ef69484cd678ede814ebc5d46bf84969b8d96051.tar.bz2
swig: Remove SWIG based python bindings
Diffstat (limited to 'swig/Makefile.am')
-rw-r--r--swig/Makefile.am34
1 files changed, 0 insertions, 34 deletions
diff --git a/swig/Makefile.am b/swig/Makefile.am
deleted file mode 100644
index 1f7bf0c..0000000
--- a/swig/Makefile.am
+++ /dev/null
@@ -1,34 +0,0 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include $(libplist_CFLAGS) $(SWIG_PYTHON_CPPFLAGS) -I$(oldincludedir)
-
-if HAVE_SWIG
-BUILT_SOURCES = imobiledevice_wrap.cxx
-SWIG_SOURCES = imobiledevice.i
-
-CLEANFILES = \
- *.pyc \
- *.pyo \
- _imobiledevice.so \
- imobiledevice.py \
- imobiledevice_wrap.cxx
-
-EXTRA_DIST = \
- __init__.py \
- imobiledevice.i
-
-swigincludedir =$(includedir)/libimobiledevice/swig
-swiginclude_HEADERS = $(SWIG_SOURCES)
-
-imobiledevicedir = $(pyexecdir)/imobiledevice
-imobiledevice_PYTHON = __init__.py
-nodist_imobiledevice_PYTHON = imobiledevice.py
-imobiledevice_LTLIBRARIES = _imobiledevice.la
-nodist__imobiledevice_la_SOURCES = imobiledevice_wrap.cxx $(SWIG_SOURCES)
-_imobiledevice_la_CFLAGS = $(PYTHON_CPPFLAGS) -I$(top_srcdir)/src
-_imobiledevice_la_LDFLAGS = -module -avoid-version $(PYTHON_LDFLAGS)
-_imobiledevice_la_LIBADD = $(top_builddir)/src/libimobiledevice.la $(libplistmm_LIBS)
-
-imobiledevice_wrap.cxx : $(SWIG_SOURCES)
- $(SWIG) $(SWIG_PYTHON_OPT) $(AM_CPPFLAGS) -I$(top_srcdir)/src -o $@ $<
-
-endif # HAVE_SWIG
-