summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2023-12-30 01:27:42 +0100
committerGravatar Nikias Bassen2023-12-30 01:27:42 +0100
commit7f781eb61215c84bd0f79838fbcb5efd66121677 (patch)
tree2741401eec23b6504e068d8640f2ac9237e3795e /tools/Makefile.am
parent76f924c2a1c61d05ece9bdc699a350ad165e3761 (diff)
downloadlibimobiledevice-7f781eb61215c84bd0f79838fbcb5efd66121677.tar.gz
libimobiledevice-7f781eb61215c84bd0f79838fbcb5efd66121677.tar.bz2
tools: Add afcclient utility
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index bd93631..4cac1fc 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -31,7 +31,8 @@ bin_PROGRAMS = \
idevicedevmodectl \
idevicenotificationproxy \
idevicecrashreport \
- idevicesetlocation
+ idevicesetlocation \
+ afcclient
idevicebtlogger_SOURCES = idevicebtlogger.c
iidevicebtlogger_CFLAGS = $(AM_CFLAGS)
@@ -132,3 +133,12 @@ idevicesetlocation_SOURCES = idevicesetlocation.c
idevicesetlocation_CFLAGS = $(AM_CFLAGS)
idevicesetlocation_LDFLAGS = $(AM_LDFLAGS)
idevicesetlocation_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
+
+afcclient_SOURCES = afcclient.c
+afcclient_CFLAGS = $(AM_CFLAGS)
+afcclient_LDFLAGS = $(AM_LDFLAGS)
+if HAVE_READLINE
+ afcclient_CFLAGS += $(readline_CFLAGS)
+ afcclient_LDFLAGS += $(readline_LIBS)
+endif
+afcclient_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(limd_glue_LIBS)