summaryrefslogtreecommitdiffstats
path: root/udev/Makefile.am
diff options
context:
space:
mode:
authorGravatar Matt Colyer2009-03-24 10:01:25 -0700
committerGravatar Matt Colyer2009-03-24 10:01:25 -0700
commit0114d8da493e69f14bc2669ae0ec6b9813b237cf (patch)
tree08ecfcb23f61ffa4b1066da4c4a2367672ab31d1 /udev/Makefile.am
parent127a5934b593ea7fd34b16477e6dd5619101bcb9 (diff)
downloadlibimobiledevice-0114d8da493e69f14bc2669ae0ec6b9813b237cf.tar.gz
libimobiledevice-0114d8da493e69f14bc2669ae0ec6b9813b237cf.tar.bz2
Added support for forcing the iPhone into configuration 3 through udev to allow automounting support.
Diffstat (limited to 'udev/Makefile.am')
-rw-r--r--udev/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/udev/Makefile.am b/udev/Makefile.am
new file mode 100644
index 0000000..27cc456
--- /dev/null
+++ b/udev/Makefile.am
@@ -0,0 +1,12 @@
+udevdir=$(sysconfdir)/udev/rules.d/
+udev_DATA=89-libiphone.rules
+
+edit = sed \
+ -e 's|@bindir[@]|$(bindir)|g'
+
+89-libiphone.rules:
+ rm -f $@ $@.tmp
+ $(edit) '$(srcdir)/$@.in' >$@.tmp
+ mv $@.tmp $@
+
+bin_SCRIPTS = set-usb-configuration-3.sh