summaryrefslogtreecommitdiffstats
path: root/3rd_party/ed25519/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '3rd_party/ed25519/Makefile.am')
-rw-r--r--3rd_party/ed25519/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/3rd_party/ed25519/Makefile.am b/3rd_party/ed25519/Makefile.am
new file mode 100644
index 0000000..d8e4e04
--- /dev/null
+++ b/3rd_party/ed25519/Makefile.am
@@ -0,0 +1,26 @@
+AUTOMAKE_OPTIONS = foreign no-dependencies
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)
+
+AM_CFLAGS = \
+ $(GLOBAL_CFLAGS) \
+ $(ssl_lib_CFLAGS)
+
+AM_LDFLAGS =
+
+noinst_LTLIBRARIES = libed25519.la
+libed25519_la_LIBADD =
+libed25519_la_LDFLAGS = $(AM_LDFLAGS) -no-undefined
+libed25519_la_SOURCES = \
+ add_scalar.c \
+ fe.c \
+ ge.c \
+ keypair.c \
+ key_exchange.c \
+ sc.c \
+ seed.c \
+ sign.c \
+ sha512.c \
+ verify.c