summaryrefslogtreecommitdiffstats
path: root/3rd_party/libsrp6a-sha512/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '3rd_party/libsrp6a-sha512/Makefile.am')
-rw-r--r--3rd_party/libsrp6a-sha512/Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/3rd_party/libsrp6a-sha512/Makefile.am b/3rd_party/libsrp6a-sha512/Makefile.am
index 8c6e2f5..2acd582 100644
--- a/3rd_party/libsrp6a-sha512/Makefile.am
+++ b/3rd_party/libsrp6a-sha512/Makefile.am
@@ -5,11 +5,9 @@ AM_CPPFLAGS = \
-I$(top_srcdir) \
-Wno-incompatible-pointer-types
-include_HEADERS = srp.h srp_aux.h cstr.h
-
AM_CFLAGS = -DHAVE_CONFIG_H
if HAVE_OPENSSL
-AM_CFLAGS += -DOPENSSL=1 -DOPENSSL_ENGINE=1 $(openssl_CFLAGS)
+AM_CFLAGS += -DOPENSSL=1 $(openssl_CFLAGS)
else
if HAVE_GCRYPT
AM_CFLAGS += -DGCRYPT=1 $(libgcrypt_CFLAGS)
@@ -25,7 +23,9 @@ noinst_LTLIBRARIES = libsrp6a-sha512.la
libsrp6a_sha512_la_SOURCES = \
t_conv.c t_math.c t_misc.c \
t_truerand.c cstr.c \
- srp.c srp6a_sha512_client.c
-if !HAVE_OPENSSL
-libsrp6a_sha512_la_SOURCES += t_sha.c
-endif
+ srp.c srp6a_sha512_client.c \
+ srp.h srp_aux.h cstr.h \
+ t_sha.c
+#if !HAVE_OPENSSL
+#libsrp6a_sha512_la_SOURCES += t_sha.c
+#endif