summaryrefslogtreecommitdiffstats
path: root/common/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'common/Makefile.am')
-rw-r--r--common/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/common/Makefile.am b/common/Makefile.am
new file mode 100644
index 0000000..ba7ed9c
--- /dev/null
+++ b/common/Makefile.am
@@ -0,0 +1,29 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)
+
+AM_CFLAGS = \
+ $(GLOBAL_CFLAGS) \
+ $(ssl_lib_CFLAGS) \
+ $(LFS_CFLAGS) \
+ $(libusbmuxd_CFLAGS) \
+ $(limd_glue_CFLAGS) \
+ $(libplist_CFLAGS)
+
+AM_LDFLAGS = \
+ $(ssl_lib_LIBS) \
+ ${libpthread_LIBS} \
+ $(libusbmuxd_LIBS) \
+ $(limd_glue_LIBS) \
+ $(libplist_LIBS)
+
+noinst_LTLIBRARIES = libinternalcommon.la
+libinternalcommon_la_LIBADD =
+libinternalcommon_la_LDFLAGS = $(AM_LDFLAGS) -no-undefined
+libinternalcommon_la_SOURCES = \
+ debug.c debug.h \
+ userpref.c userpref.h
+
+if WIN32
+libinternalcommon_la_LIBADD += -lole32 -lws2_32
+endif