summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac101
1 files changed, 84 insertions, 17 deletions
diff --git a/configure.ac b/configure.ac
index cdd388b..9856ae2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ([2.68])
-AC_INIT([libimobiledevice], [1.3.1], [https://github.com/libimobiledevice/libimobiledevice/issues], [], [https://libimobiledevice.org])
+AC_INIT([libimobiledevice], [m4_esyscmd(./git-version-gen $RELEASE_VERSION)], [https://github.com/libimobiledevice/libimobiledevice/issues], [], [https://libimobiledevice.org])
AM_INIT_AUTOMAKE([dist-bzip2 no-dist-gzip check-news])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES])
AC_CONFIG_SRCDIR([src/])
@@ -17,12 +17,18 @@ dnl libtool versioning
# CURRENT : REVISION : AGE
LIBIMOBILEDEVICE_SO_VERSION=6:0:0
+AC_SUBST(LIBIMOBILEDEVICE_SO_VERSION)
+
+# Check if we have a version defined
+if test -z $PACKAGE_VERSION; then
+ AC_MSG_ERROR([PACKAGE_VERSION is not defined. Make sure to configure a source tree checked out from git or that .tarball-version is present.])
+fi
+
dnl Minimum package versions
LIBUSBMUXD_VERSION=2.0.2
-LIBPLIST_VERSION=2.2.0
+LIBPLIST_VERSION=2.3.0
LIMD_GLUE_VERSION=1.0.0
-AC_SUBST(LIBIMOBILEDEVICE_SO_VERSION)
AC_SUBST(LIBUSBMUXD_VERSION)
AC_SUBST(LIBPLIST_VERSION)
AC_SUBST(LIMD_GLUE_VERSION)
@@ -37,9 +43,21 @@ LT_INIT
PKG_CHECK_MODULES(libusbmuxd, libusbmuxd-2.0 >= $LIBUSBMUXD_VERSION)
PKG_CHECK_MODULES(libplist, libplist-2.0 >= $LIBPLIST_VERSION)
PKG_CHECK_MODULES(limd_glue, libimobiledevice-glue-1.0 >= $LIMD_GLUE_VERSION)
+AC_ARG_WITH([readline],
+ [AS_HELP_STRING([--without-readline],
+ [build without support for libreadline (default is yes)])],
+ [check_libreadline=false],
+ [check_libreadline=true])
+if test "$check_libreadline" = "true"; then
+ PKG_CHECK_MODULES(readline, readline >= 1.0, have_readline=yes, have_readline=no)
+ if test "x$have_readline" = "xyes"; then
+ AC_DEFINE(HAVE_READLINE, 1, [Define if readline library is available])
+ fi
+fi
+AM_CONDITIONAL([HAVE_READLINE],[test "x$have_readline" = "xyes"])
# Checks for header files.
-AC_CHECK_HEADERS([stdint.h stdlib.h string.h gcrypt.h])
+AC_CHECK_HEADERS([stdint.h stdlib.h string.h sys/time.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -64,6 +82,8 @@ if test "x$ac_cv_have_endian_h" = "xno"; then
fi
fi
+AC_CHECK_DECL([plist_from_json], [AC_DEFINE([HAVE_PLIST_JSON], [1], [Define if libplist has JSON support])], [], [[#include <plist/plist.h>]])
+
# Check for operating system
AC_MSG_CHECKING([for platform-specific build settings])
case ${host_os} in
@@ -74,6 +94,7 @@ case ${host_os} in
;;
darwin*)
AC_MSG_RESULT([${host_os}])
+ darwin=true
;;
*)
AC_MSG_RESULT([${host_os}])
@@ -82,6 +103,7 @@ case ${host_os} in
;;
esac
AM_CONDITIONAL(WIN32, test x$win32 = xtrue)
+AM_CONDITIONAL(DARWIN, test x$darwin = xtrue)
# Check if the C compiler supports __attribute__((constructor))
AC_CACHE_CHECK([wether the C compiler supports constructor/destructor attributes],
@@ -110,9 +132,9 @@ AC_ARG_WITH([cython],
[build_cython=false],
[build_cython=true])
if test "$build_cython" = "true"; then
- AC_PROG_CYTHON([0.17.0])
+ AC_PROG_CYTHON([3.0.0])
if [test "x$CYTHON" != "xfalse"]; then
- AM_PATH_PYTHON([2.3], [
+ AM_PATH_PYTHON([3.0], [
CYTHON_PYTHON
AS_COMPILER_FLAG([-Wno-cast-function-type -Werror], [
CYTHON_CFLAGS+=" -Wno-cast-function-type"
@@ -155,7 +177,7 @@ AC_ARG_WITH([mbedtls],
[Do not look for mbedtls])],
[use_mbedtls=$withval],
[use_mbedtls=no])
-if test "x$use_mbedtls" == "xyes"; then
+if test "x$use_mbedtls" = "xyes"; then
default_openssl=no
fi
AC_ARG_WITH([gnutls],
@@ -163,7 +185,7 @@ AC_ARG_WITH([gnutls],
[Do not look for GnuTLS])],
[use_gnutls=$withval],
[use_gnutls=no])
-if test "x$use_gnutls" == "xyes"; then
+if test "x$use_gnutls" = "xyes"; then
default_openssl=no
fi
AC_ARG_WITH([openssl],
@@ -172,7 +194,7 @@ AC_ARG_WITH([openssl],
[use_openssl=$withval],
[use_openssl=$default_openssl])
-if test "x$use_mbedtls" == "xyes"; then
+if test "x$use_mbedtls" = "xyes"; then
CACHED_CFLAGS="$CFLAGS"
conf_mbedtls_CFLAGS=""
if test -n "$mbedtls_INCLUDES"; then
@@ -199,7 +221,7 @@ if test "x$use_mbedtls" == "xyes"; then
ssl_requires=""
AC_SUBST(ssl_requires)
else
- if test "x$use_openssl" == "xyes"; then
+ if test "x$use_openssl" = "xyes"; then
pkg_req_openssl="openssl >= 0.9.8"
PKG_CHECK_MODULES(openssl, $pkg_req_openssl, have_openssl=yes, have_openssl=no)
if test "x$have_openssl" != "xyes"; then
@@ -212,16 +234,47 @@ else
AC_SUBST(ssl_lib_LIBS)
ssl_provider="OpenSSL";
ssl_requires="$pkg_req_openssl"
+ # test if we have LibreSSL
+ CACHED_CFLAGS="$CFLAGS"
+ CFLAGS="$openssl_CFLAGS"
+ ac_cv_is_libressl=no
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
+ [[
+ #include <openssl/opensslv.h>
+ ]], [
+ #ifndef LIBRESSL_VERSION_NUMBER
+ #error No LibreSSL
+ #endif
+ ])],
+ [
+ ac_cv_is_libressl=yes
+ ],
+ )
+ CFLAGS="$CACHED_CFLAGS"
+ if test "x$ac_cv_is_libressl" = "xyes"; then
+ ssl_provider="LibreSSL"
+ case ${host_os} in
+ darwin*)
+ case ${openssl_LIBS} in
+ *.tbd*)
+ # using system LibreSSL on Darwin
+ ssl_requires=""
+ ;;
+ esac
+ ;;
+ esac
+ fi
AC_SUBST(ssl_requires)
fi
else
- if test "x$use_gnutls" == "xyes"; then
+ if test "x$use_gnutls" = "xyes"; then
pkg_req_gnutls="gnutls >= 2.2.0"
pkg_req_libtasn1="libtasn1 >= 1.1"
PKG_CHECK_MODULES(libgnutls, $pkg_req_gnutls)
+ AC_CHECK_HEADERS([gcrypt.h])
AC_CHECK_LIB(gcrypt, gcry_control, [AC_SUBST(libgcrypt_LIBS,[-lgcrypt])], [AC_MSG_ERROR([libgcrypt is required to build libimobiledevice with GnuTLS])])
PKG_CHECK_MODULES(libtasn1, $pkg_req_libtasn1)
-
+ AC_DEFINE(HAVE_GCRYPT, 1, [Define if you have libgcrypt support])
AC_DEFINE(HAVE_GNUTLS, 1, [Define if you have GnuTLS support])
ssl_lib_CFLAGS="$libgnutls_CFLAGS $libtasn1_CFLAGS $libgcrypt_CFLAGS"
ssl_lib_LIBS="$libgnutls_LIBS $libtasn1_LIBS $libgcrypt_LIBS"
@@ -235,6 +288,17 @@ else
fi
fi
fi
+AM_CONDITIONAL(HAVE_MBEDTLS, test "x$use_mbedtls" = "xyes")
+AM_CONDITIONAL(HAVE_OPENSSL, test "x$use_openssl" = "xyes")
+AM_CONDITIONAL(HAVE_GCRYPT, test "x$use_gnutls" = "xyes")
+
+AC_ARG_ENABLE([wireless-pairing],
+ [AS_HELP_STRING([--disable-wireless-pairing],
+ [Do not build with wirless pairing support (default is yes)])])
+if test "$enable_wireless_pairing" != "no"; then
+ AC_DEFINE(HAVE_WIRELESS_PAIRING,1,[Define if building with wireless pairing support])
+fi
+AM_CONDITIONAL(HAVE_WIRELESS_PAIRING, test "$enable_wireless_pairing" != "no")
AC_ARG_ENABLE([debug],
[AS_HELP_STRING([--enable-debug],
@@ -249,12 +313,12 @@ else
fi
AS_COMPILER_FLAGS(GLOBAL_CFLAGS, "-Wall -Wextra -Wmissing-declarations -Wredundant-decls -Wshadow -Wpointer-arith -Wwrite-strings -Wswitch-default -Wno-unused-parameter -fsigned-char -fvisibility=hidden")
-AC_SUBST(GLOBAL_CFLAGS)
-case "$GLOBAL_CFLAGS" in
- *-fvisibility=hidden*)
- AC_DEFINE([HAVE_FVISIBILITY], [1], [Define if compiled with -fvisibility=hidden])
-esac
+if test "x$enable_static" = "xyes" -a "x$enable_shared" = "xno"; then
+ GLOBAL_CFLAGS+=" -DLIBIMOBILEDEVICE_STATIC"
+fi
+
+AC_SUBST(GLOBAL_CFLAGS)
# check for large file support
AC_SYS_LARGEFILE
@@ -263,6 +327,9 @@ m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
AC_CONFIG_FILES([
Makefile
+3rd_party/Makefile
+3rd_party/ed25519/Makefile
+3rd_party/libsrp6a-sha512/Makefile
common/Makefile
src/Makefile
src/libimobiledevice-1.0.pc