summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am27
1 files changed, 19 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 183a745..58cf07c 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,32 +1,41 @@
AM_CPPFLAGS = \
-I$(top_srcdir)/include \
+ -I$(top_srcdir)/3rd_party/libsrp6a-sha512 \
+ -I$(top_srcdir)/3rd_party/ed25519 \
-I$(top_srcdir)
AM_CFLAGS = \
$(GLOBAL_CFLAGS) \
- $(libusbmuxd_CFLAGS) \
- $(libplist_CFLAGS) \
- $(limd_glue_CFLAGS) \
$(ssl_lib_CFLAGS) \
$(LFS_CFLAGS) \
- $(PTHREAD_CFLAGS)
+ $(PTHREAD_CFLAGS) \
+ $(libusbmuxd_CFLAGS) \
+ $(libplist_CFLAGS) \
+ $(limd_glue_CFLAGS)
AM_LDFLAGS = \
+ $(ssl_lib_LIBS) \
+ $(PTHREAD_LIBS) \
$(libusbmuxd_LIBS) \
$(libplist_LIBS) \
- $(limd_glue_LIBS) \
- $(ssl_lib_LIBS) \
- $(PTHREAD_LIBS)
+ $(limd_glue_LIBS)
lib_LTLIBRARIES = libimobiledevice-1.0.la
libimobiledevice_1_0_la_LIBADD = $(top_builddir)/common/libinternalcommon.la
+if HAVE_WIRELESS_PAIRING
+libimobiledevice_1_0_la_LIBADD += $(top_builddir)/3rd_party/ed25519/libed25519.la $(top_builddir)/3rd_party/libsrp6a-sha512/libsrp6a-sha512.la
+endif
libimobiledevice_1_0_la_LDFLAGS = $(AM_LDFLAGS) -version-info $(LIBIMOBILEDEVICE_SO_VERSION) -no-undefined
+if DARWIN
+libimobiledevice_1_0_la_LDFLAGS += -framework CoreFoundation -framework SystemConfiguration
+endif
libimobiledevice_1_0_la_SOURCES = \
idevice.c idevice.h \
service.c service.h \
property_list_service.c property_list_service.h \
device_link_service.c device_link_service.h \
lockdown.c lockdown.h \
+ lockdown-cu.c \
afc.c afc.h \
file_relay.c file_relay.h \
notification_proxy.c notification_proxy.h \
@@ -47,7 +56,9 @@ libimobiledevice_1_0_la_SOURCES = \
mobileactivation.c mobileactivation.h \
preboard.c preboard.h \
companion_proxy.c companion_proxy.h \
- syslog_relay.c syslog_relay.h
+ reverse_proxy.c reverse_proxy.h \
+ syslog_relay.c syslog_relay.h \
+ bt_packet_logger.c bt_packet_logger.h
if WIN32
libimobiledevice_1_0_la_LDFLAGS += -avoid-version -static-libgcc