summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2014-10-03 16:00:26 +0200
committerGravatar Martin Szulecki2014-10-03 16:00:26 +0200
commit250d32a3df8f4dc06abbadd05a12d0bb9c1715bf (patch)
tree00dd45d1674fa78cf0fabbfd0c7cf32652fe260f /configure.ac
parent743cfa3e21313132517b3f8d730530eb34ed8723 (diff)
downloadlibirecovery-250d32a3df8f4dc06abbadd05a12d0bb9c1715bf.tar.gz
libirecovery-250d32a3df8f4dc06abbadd05a12d0bb9c1715bf.tar.bz2
Avoid exporting non-public symbols
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f4bbad3..07ebf77 100644
--- a/configure.ac
+++ b/configure.ac
@@ -87,9 +87,14 @@ case ${host_os} in
esac
AM_CONDITIONAL(WIN32, test x$win32 = xtrue)
-AS_COMPILER_FLAGS(GLOBAL_CFLAGS, "-Wall -Wextra -Wmissing-declarations -Wredundant-decls -Wshadow -Wpointer-arith -Wwrite-strings -Wswitch-default -Wno-unused-parameter")
+AS_COMPILER_FLAGS(GLOBAL_CFLAGS, "-Wall -Wextra -Wmissing-declarations -Wredundant-decls -Wshadow -Wpointer-arith -Wwrite-strings -Wswitch-default -Wno-unused-parameter -fvisibility=hidden")
AC_SUBST(GLOBAL_CFLAGS)
+case "$GLOBAL_CFLAGS" in
+ *-fvisibility=hidden*)
+ AC_DEFINE([HAVE_FVISIBILITY], [1], [Define if compiled with -fvisibility=hidden])
+esac
+
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
AC_OUTPUT([