summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2024-01-29 05:41:49 +0100
committerGravatar Nikias Bassen2024-01-29 05:41:49 +0100
commitfec1d79ee5ff7def2d2208767fb31ce5978f587c (patch)
tree0778aa7547c5854bbe9cd493a13f6b77adbb5306 /configure.ac
parent4fa49416d47076a026d7d2858dbe2002aaa1537f (diff)
downloadlibirecovery-fec1d79ee5ff7def2d2208767fb31ce5978f587c.tar.gz
libirecovery-fec1d79ee5ff7def2d2208767fb31ce5978f587c.tar.bz2
Fix IRECV_API definitions
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2b12d8f..fdecca3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -141,6 +141,11 @@ AS_IF([test "x$with_dummy" = "xyes"], [
])
AS_COMPILER_FLAGS(GLOBAL_CFLAGS, "-Wall -Wextra -Wmissing-declarations -Wredundant-decls -Wshadow -Wpointer-arith -Wwrite-strings -Wswitch-default -Wno-unused-parameter -fvisibility=hidden")
+
+if test "x$enable_static" = "xyes" -a "x$enable_shared" = "xno"; then
+ GLOBAL_CFLAGS+=" -DIRECV_STATIC"
+fi
+
AC_SUBST(GLOBAL_CFLAGS)
AC_SUBST(GLOBAL_LDFLAGS)