summaryrefslogtreecommitdiffstats
path: root/udev/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'udev/Makefile.am')
-rw-r--r--udev/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/udev/Makefile.am b/udev/Makefile.am
new file mode 100644
index 0000000..2a7ad98
--- /dev/null
+++ b/udev/Makefile.am
@@ -0,0 +1,21 @@
+if WITH_UDEV
+edit = \
+ $(SED) -r \
+ -e 's|@udev_activation_rule[@]|$(udev_activation_rule)|g' \
+ < $< > $@ || rm $@
+
+udevrules_DATA = \
+ 39-libirecovery.rules
+
+39-libirecovery.rules: 39-libirecovery.rules.in
+ $(edit)
+
+EXTRA_DIST = \
+ 39-libirecovery.rules.in
+
+MAINTAINERCLEANFILES = \
+ 39-libirecovery.rules
+
+CLEANFILES = \
+ 39-libirecovery.rules
+endif