summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2024-02-21 01:01:00 +0100
committerGravatar Nikias Bassen2024-02-21 01:01:00 +0100
commit86c3ef2de8b0b4e2af246410c42cbf03788dd589 (patch)
treec75b11f304c2f8d59aa66e88d2a62b379040353d /Makefile.am
parent3ca4f1427e2201be0fce450e7788a4e3499786a8 (diff)
downloadlibplist-86c3ef2de8b0b4e2af246410c42cbf03788dd589.tar.gz
libplist-86c3ef2de8b0b4e2af246410c42cbf03788dd589.tar.bz2
docs: Use README.md to generate mainpage with doxygen
Actually we are using a slightly modified one that removes the `Table of Contents` section and replaces it with the doxygen-compatible `[TOC]` to auto-generate a TOC that has working links.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7da967d..f44a6bc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,4 +25,7 @@ docs/html: $(top_builddir)/doxygen.cfg $(top_srcdir)/include/plist/*.h
rm -rf docs/html
doxygen doxygen.cfg
-docs: doxygen.cfg docs/html
+docs/README.doxygen.md: README.md
+ awk '/\#\# Table of Contents/{while(getline && $$0 != ""){}{print "[TOC]"}}1' README.md > $@
+
+docs: doxygen.cfg docs/README.doxygen.md docs/html