summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Christophe Fergeau2017-04-20 12:38:09 +0200
committerGravatar Nikias Bassen2017-04-20 12:38:09 +0200
commit054578a2d842f53a061c0a6ddaf6bfc849be0738 (patch)
tree135e0569d64044555c8c6b80e183ead923dedaf1 /configure.ac
parentd0193690c8d7b8b4adb8fac4fc9289ebe07576f3 (diff)
downloadlibplist-054578a2d842f53a061c0a6ddaf6bfc849be0738.tar.gz
libplist-054578a2d842f53a061c0a6ddaf6bfc849be0738.tar.bz2
autofoo: Ensure that 'make distcheck' doesn't fail when cython is not installed
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index ddd5b81..61eb8ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,21 +117,17 @@ if [test "x$CYTHON" != "xfalse"]; then
CYTHON_PLIST_INCLUDE_DIR=$($PKG_CONFIG --variable=includedir libplist)/plist/cython
if [test ! -d "$CYTHON_PLIST_INCLUDE_DIR"]; then
CYTHON_PLIST_INCLUDE_DIR=.
- CYTHON_SUB=cython
cython_python_bindings=yes
AC_MSG_RESULT([Using built-in libplist Cython bindings (assuming this is a first build)])
else
AC_SUBST([CYTHON_PLIST_INCLUDE_DIR])
AC_MSG_RESULT([$CYTHON_PLIST_INCLUDE_DIR])
- CYTHON_SUB=cython
cython_python_bindings=yes
fi
else
- CYTHON_SUB=
cython_python_bindings=no
fi
-AM_CONDITIONAL([HAVE_CYTHON],[test "x$CYTHON_SUB" = "xcython"])
-AC_SUBST([CYTHON_SUB])
+AM_CONDITIONAL([HAVE_CYTHON],[test "x$cython_python_bindings" = "xyes"])
AS_COMPILER_FLAGS(GLOBAL_CFLAGS, "-Wall -Wextra -Wredundant-decls -Wshadow -Wpointer-arith -Wwrite-strings -Wswitch-default -Wno-unused-parameter -Wno-strict-aliasing -fvisibility=hidden $PTHREAD_CFLAGS")
GLOBAL_LDFLAGS="$PTHREAD_LIBS"