summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Jonathan Beck2009-03-27 18:46:59 +0100
committerGravatar Jonathan Beck2009-03-27 18:46:59 +0100
commit26aa1fe88c19412e81db02f3a6397b22465ce565 (patch)
treeb7eddc7095d44fbd886d28ae51d3053bec5f184b /configure.ac
parentc99881e673b58efba240d6b9440768eace28b027 (diff)
downloadlibplist-26aa1fe88c19412e81db02f3a6397b22465ce565.tar.gz
libplist-26aa1fe88c19412e81db02f3a6397b22465ce565.tar.bz2
Remove autotools.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac56
1 files changed, 0 insertions, 56 deletions
diff --git a/configure.ac b/configure.ac
deleted file mode 100644
index 7c9cbab..0000000
--- a/configure.ac
+++ /dev/null
@@ -1,56 +0,0 @@
-# -*- Autoconf -*-
-# Process this file with autoconf to produce a configure script.
-
-AC_PREREQ(2.61)
-AC_INIT(libplist, 0.1.0, nospam@nowhere.com)
-AM_INIT_AUTOMAKE(libplist, 0.1.0)
-AC_CONFIG_SRCDIR([src/])
-AC_CONFIG_HEADER([config.h])
-AC_CONFIG_MACRO_DIR([m4])
-
-AC_PROG_LIBTOOL
-
-AM_PATH_PYTHON(2.3)
-AC_PROG_SWIG(1.3.21)
-SWIG_PYTHON
-
-
-# Checks for programs.
-AC_PROG_CC
-AM_PROG_CC_C_O
-
-# Checks for libraries.
-PKG_CHECK_MODULES(libxml2, libxml-2.0 >= 2.6.30)
-PKG_CHECK_MODULES(libglib2, glib-2.0 >= 2.14.1)
-
-# Checks for header files.
-AC_HEADER_STDC
-AC_CHECK_HEADERS([stdint.h stdlib.h string.h])
-
-# Checks for typedefs, structures, and compiler characteristics.
-AC_C_CONST
-AC_TYPE_SIZE_T
-AC_TYPE_SSIZE_T
-AC_TYPE_UINT16_T
-AC_TYPE_UINT32_T
-AC_TYPE_UINT64_T
-AC_TYPE_UINT8_T
-
-# Checks for library functions.
-AC_FUNC_MALLOC
-AC_FUNC_REALLOC
-AC_CHECK_FUNCS([strcasecmp strdup strerror strndup])
-
-AC_ARG_ENABLE([debug-code],
- [AS_HELP_STRING([--disable-debug-code],
- [disable debug message reporting in library (default is yes)])],
- [no_debug_code=false],
- [no_debug_code=true])
-if test "$no_debug_code" = true; then
- AC_DEFINE(STRIP_DEBUG_CODE,1,[Strip debug reporting code])
-fi
-
-AS_COMPILER_FLAGS(GLOBAL_CFLAGS, "-Wall -Wextra -Wmissing-declarations -Wredundant-decls -Wshadow -Wpointer-arith -Wwrite-strings -Wswitch-default -Wno-unused-parameter")
-AC_SUBST(GLOBAL_CFLAGS)
-
-AC_OUTPUT(Makefile src/Makefile include/Makefile plutil/Makefile swig/Makefile libplist.pc)