summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Jonathan Beck2008-12-13 12:21:03 +0100
committerGravatar Jonathan Beck2008-12-13 12:21:03 +0100
commit3fdd24aea06a9bf38d9d34fb8bccbb7023ed3100 (patch)
tree1080d26eca01c885efb33f3f98821a981a25e8b4 /configure.ac
parent3d8ba053deeacd74e621469d3d45d1db38ee411a (diff)
downloadlibplist-3fdd24aea06a9bf38d9d34fb8bccbb7023ed3100.tar.gz
libplist-3fdd24aea06a9bf38d9d34fb8bccbb7023ed3100.tar.bz2
Fork libiphone and remove anything non plist specific.
Update library and make related files acordingly .
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 5 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 286b1d8..a665182 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,8 +2,8 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.61)
-AC_INIT(libiphone, 0.1.0, nospam@nowhere.com)
-AM_INIT_AUTOMAKE(libiphone, 0.1.0)
+AC_INIT(libplist, 0.1.0, nospam@nowhere.com)
+AM_INIT_AUTOMAKE(libplist, 0.1.0)
AC_CONFIG_SRCDIR([src/])
AC_CONFIG_HEADER([config.h])
@@ -15,15 +15,11 @@ AM_PROG_CC_C_O
# Checks for libraries.
PKG_CHECK_MODULES(libxml2, libxml-2.0 >= 2.6.30)
-PKG_CHECK_MODULES(libusb, libusb >= 0.1.12)
PKG_CHECK_MODULES(libglib2, glib-2.0 >= 2.14.1)
-PKG_CHECK_MODULES(libgthread2, gthread-2.0 >= 2.14.1)
-PKG_CHECK_MODULES(libgnutls, gnutls >= 1.6.3 gnutls <= 2.5.0 )
-PKG_CHECK_MODULES(libtasn1, libtasn1 >= 1.1)
# Checks for header files.
AC_HEADER_STDC
-AC_CHECK_HEADERS([arpa/inet.h stdint.h stdlib.h string.h])
+AC_CHECK_HEADERS([stdint.h stdlib.h string.h])
# Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST
@@ -31,6 +27,7 @@ AC_TYPE_SIZE_T
AC_TYPE_SSIZE_T
AC_TYPE_UINT16_T
AC_TYPE_UINT32_T
+AC_TYPE_UINT64_T
AC_TYPE_UINT8_T
# Checks for library functions.
@@ -38,18 +35,6 @@ AC_FUNC_MALLOC
AC_FUNC_REALLOC
AC_CHECK_FUNCS([strcasecmp strdup strerror strndup])
-AC_ARG_ENABLE([dev-tools],
- [AS_HELP_STRING([--enable-dev-tools],
- [build development helper tools (default is no)])],
- [build_dev_tools=true],
- [build_dev_tools=false])
-if test "$build_dev_tools" = true; then
- DEV_SUB=dev
-else
- DEV_SUB=
-fi
-AC_SUBST([DEV_SUB])
-
AC_ARG_ENABLE([debug-code],
[AS_HELP_STRING([--disable-debug-code],
[disable debug message reporting in library (default is yes)])],
@@ -59,4 +44,4 @@ if test "$no_debug_code" = true; then
AC_DEFINE(STRIP_DEBUG_CODE,1,[Strip debug reporting code])
fi
-AC_OUTPUT(Makefile src/Makefile include/Makefile fdi/Makefile dev/Makefile libiphone-1.0.pc)
+AC_OUTPUT(Makefile src/Makefile include/Makefile libplist-1.0.pc)