summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Jonathan Beck2009-01-11 20:44:33 +0100
committerGravatar Jonathan Beck2009-01-11 20:44:33 +0100
commit74dae54b1b092aca744b4df6668569d6fc1153b5 (patch)
tree46d0e9ade9da94d12a57a06032f4fe81716ff8f5 /configure.ac
parented5f0b7154a5f653c240e6962098ae7b28ab61e5 (diff)
downloadlibplist-74dae54b1b092aca744b4df6668569d6fc1153b5.tar.gz
libplist-74dae54b1b092aca744b4df6668569d6fc1153b5.tar.bz2
Add a pythyon binding to the library (using SWIG).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2f171e1..fb8a484 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,6 +10,11 @@ AC_CONFIG_MACRO_DIR([m4])
AC_PROG_LIBTOOL
+AM_PATH_PYTHON(2.3)
+AC_PROG_SWIG(1.3.21)
+SWIG_PYTHON
+
+
# Checks for programs.
AC_PROG_CC
AM_PROG_CC_C_O
@@ -48,4 +53,4 @@ fi
AS_COMPILER_FLAGS(GLOBAL_CFLAGS, "-Wall -Wextra -Wmissing-declarations -Wredundant-decls -Wshadow -Wpointer-arith -Wwrite-strings -Wswitch-default -Wno-unused-parameter")
AC_SUBST(GLOBAL_CFLAGS)
-AC_OUTPUT(Makefile src/Makefile include/Makefile plutil/Makefile libplist-1.0.pc)
+AC_OUTPUT(Makefile src/Makefile include/Makefile plutil/Makefile swig/Makefile libplist-1.0.pc)