summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Florian Weimer2023-12-18 11:14:40 +0100
committerGravatar Florian Weimer2023-12-18 11:14:40 +0100
commitb3cf5bec39de69bf06c7813689f03cbe58f45ca9 (patch)
tree8f7e043d5b3cc1ef573545056cfb7211cd07f610 /configure.ac
parent8487d23fd2ab5683d631fd41e5f6a2f5a44d867a (diff)
downloadlibplist-b3cf5bec39de69bf06c7813689f03cbe58f45ca9.tar.gz
libplist-b3cf5bec39de69bf06c7813689f03cbe58f45ca9.tar.bz2
configure: Use string for tm_zone assignment
This matches what the actual sources do. Clang 16 and GCC 14 no longer support converting ints to pointers implicitly, so the configure probe always fails with these compilers.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 0fd1364..c6cb4bc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,7 +129,7 @@ AC_CACHE_CHECK(for tm_zone in struct tm, ac_cv_struct_tm_zone,
#include <time.h>
], [
struct tm tm;
- tm.tm_zone = 1;
+ tm.tm_zone = (char*)"UTC";
])],
[ac_cv_struct_tm_zone=yes],
[ac_cv_struct_tm_zone=no]