summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2016-12-27 15:33:20 +0100
committerGravatar Nikias Bassen2016-12-27 15:33:20 +0100
commitf0b5f30d0809aeb1db645c8060734f877de79d66 (patch)
tree06f7d9a8eaa57d280782e93c5c78e0308d27135b /configure.ac
parent19b79a93f5e45df7901091e9af6f2a6a6189c65b (diff)
downloadlibplist-f0b5f30d0809aeb1db645c8060734f877de79d66.tar.gz
libplist-f0b5f30d0809aeb1db645c8060734f877de79d66.tar.bz2
Remove check for pthread on macOS to suppress clang compiler warning
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 8 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 4eb1032..d638bdf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,26 +56,24 @@ AC_C_BIGENDIAN([AC_DEFINE([__BIG_ENDIAN__], [1], [big endian])],
# Check for operating system
-AC_MSG_CHECKING([whether to enable WIN32 build settings])
+AC_MSG_CHECKING([wether we need platform-specific build settings])
case ${host_os} in
*mingw32*|*cygwin*)
- win32=true
AC_MSG_RESULT([yes])
AC_SUBST(WINDRES)
+ win32=true
;;
- *)
- win32=false
+ darwin*)
AC_MSG_RESULT([no])
;;
+ *)
+ AC_MSG_RESULT([yes])
+ AX_PTHREAD([], [AC_MSG_ERROR([pthread is required to build libplist])])
+ AC_CHECK_LIB(pthread, [pthread_once], [], [AC_MSG_ERROR([pthread with pthread_once required to build libplist])])
+ ;;
esac
AM_CONDITIONAL(WIN32, test x$win32 = xtrue)
-# if we are not on win32, check for pthread
-if test x"$win32" != x"true"; then
- AX_PTHREAD([], [AC_MSG_ERROR([pthread is required to build libplist])])
- AC_CHECK_LIB(pthread, [pthread_once], [], [AC_MSG_ERROR([pthread with pthread_once required to build libplist])])
-fi
-
# Check if struct tm has a tm_gmtoff member
AC_CACHE_CHECK(for tm_gmtoff in struct tm, ac_cv_struct_tm_gmtoff,
AC_TRY_COMPILE([