summaryrefslogtreecommitdiffstats
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2016-06-29 05:49:53 +0200
committerGravatar Nikias Bassen2016-06-29 05:49:53 +0200
commit02bd8acd41d1ed7891100fa0057981e98a0dbdad (patch)
treed15490d7fa4f6d951d70d34cae166445c8983896 /test/Makefile.am
parentacd226d1f71a78dd23b47a9a5c4ca8cf8068d509 (diff)
downloadlibplist-02bd8acd41d1ed7891100fa0057981e98a0dbdad.tar.gz
libplist-02bd8acd41d1ed7891100fa0057981e98a0dbdad.tar.bz2
test: Add another test case for signed/unsigned (multiple) integers
Apart from testing the actual integer signed vs. unsigned value storage and conversion, this test will check that the binary plist optimization is not re-using existing values. Basically it will test the fix that was introduced with commit acd226d1f71a78dd23b47a9a5c4ca8cf8068d509.
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 1f084db..522c499 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -26,6 +26,7 @@ TESTS = \
timezone2.test \
signedunsigned1.test \
signedunsigned2.test \
+ signedunsigned3.test \
hex.test \
order.test \
recursion.test \