summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 18 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 5f36fd7..f44a6bc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,18 +1,31 @@
AUTOMAKE_OPTIONS = foreign
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = libcnary src include tools test
+SUBDIRS = libcnary src include tools docs
+
if HAVE_CYTHON
SUBDIRS += cython
endif
+
+if BUILD_TESTS
+SUBDIRS += test
+endif
+
if BUILD_FUZZERS
SUBDIRS += fuzz
endif
+EXTRA_DIST = \
+ README.md \
+ git-version-gen
+
+dist-hook:
+ echo $(VERSION) > $(distdir)/.tarball-version
+
docs/html: $(top_builddir)/doxygen.cfg $(top_srcdir)/include/plist/*.h
- rm -rf docs
+ rm -rf docs/html
doxygen doxygen.cfg
-docs: doxygen.cfg docs/html
+docs/README.doxygen.md: README.md
+ awk '/\#\# Table of Contents/{while(getline && $$0 != ""){}{print "[TOC]"}}1' README.md > $@
-clean-local:
- rm -rf docs
+docs: doxygen.cfg docs/README.doxygen.md docs/html