summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 881c49d..62f8189 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,6 +5,16 @@ AM_INIT_AUTOMAKE(libvformat, 1.2.0)
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES])
AM_CONFIG_HEADER(config.h)
+dnl libtool versioning
+# +1 : 0 : +1 == adds new functions to the interface
+# +1 : 0 : 0 == changes or removes functions (changes include both
+# changes to the signature and the semantic)
+# ? :+1 : ? == just internal changes
+# CURRENT : REVISION : AGE
+LIBVFORMAT_SO_VERSION=0:0:0
+
+AC_SUBST(LIBVFORMAT_SO_VERSION)
+
# Checks for programs.
# AC_PROG_CC