summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ab68899..9d46ceb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -23,6 +23,20 @@ AC_FUNC_MKTIME
AC_FUNC_STAT
AC_CHECK_FUNCS([atexit memset strstr])
+AC_ARG_ENABLE([docs],
+ [AS_HELP_STRING([--enable-docs],
+ [build documentation (default is no)])],
+ [build_docs=true],
+ [build_docs=false])
+if test "$build_docs" = true; then
+ DOC_SUB=doc
+else
+ DOC_SUB=
+fi
+
+AM_CONDITIONAL([ENABLE_DOCS],[test "x$DOC_SUB" = "xdoc"])
+AC_SUBST([DOC_SUB])
+
AC_OUTPUT([Makefile src/Makefile vformat/Makefile test/Makefile doc/Makefile])
#AC_CONFIG_FILES([])