summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2013-12-13 04:14:53 +0100
committerGravatar Nikias Bassen2013-12-13 04:14:53 +0100
commit3537f78a98111b88aab5e2d94dda340cf09be5af (patch)
treec52974b3f21e0ae395256b3ebaecca66cea8177e /configure.ac
parent4c9a8a7268d51c657d1b9b5b8334298bd6d62c9a (diff)
downloadusbmuxd-3537f78a98111b88aab5e2d94dda340cf09be5af.tar.gz
usbmuxd-3537f78a98111b88aab5e2d94dda340cf09be5af.tar.bz2
make libplist/protov1 support mandatory
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 1 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index 3067304..9e113d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,31 +17,10 @@ AC_PROG_LIBTOOL
# Checks for libraries.
PKG_CHECK_MODULES(libusb, libusb-1.0 >= 1.0.3)
-PKG_CHECK_MODULES(libplist, libplist >= 1.9, have_plist=yes, have_plist=no)
+PKG_CHECK_MODULES(libplist, libplist >= 1.11)
PKG_CHECK_MODULES(libimobiledevice, libimobiledevice-1.0 >= 1.1.6, have_limd=yes, have_limd=no)
AC_CHECK_LIB(pthread, [pthread_create, pthread_mutex_lock], [AC_SUBST(libpthread_LIBS,[-lpthread])], [AC_MSG_ERROR([libpthread is required to build usbmuxd])])
-AC_ARG_WITH([protov1],
- [AS_HELP_STRING([--without-protov1],
- [do not build with protocol v1 support (default is yes)])],
- [with_protov1=no],
- [with_protov1=yes])
-
-if test "x$have_plist" = "xyes"; then
- if test "x$with_protov1" != "xyes"; then
- have_plist=no
- echo "*** Note: Protocol V1 support has been disabled ***"
- else
- AC_DEFINE(HAVE_PLIST, 1, [Define if you have libplist support])
- AC_SUBST(libplist_CFLAGS)
- AC_SUBST(libplist_LIBS)
- fi
-else
- if test "x$with_protov1" == "xyes"; then
- AC_MSG_ERROR([protocol V1 support requested but libplist could not be found])
- fi
-fi
-
AC_ARG_WITH([preflight],
[AS_HELP_STRING([--without-preflight],
[do not build with preflight worker support (default is yes)])],
@@ -112,7 +91,6 @@ Configuration for $PACKAGE $VERSION:
-------------------------------------------
Install prefix: ...........: $prefix
- Protocol v1 support: ......: $have_plist
Preflight worker support ..: $have_limd
Now type 'make' to build $PACKAGE $VERSION,