summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2023-09-18 12:01:58 +0200
committerGravatar Nikias Bassen2023-09-18 12:01:58 +0200
commit56f013bd36652edb5034652dbf13719094dee45b (patch)
tree6fd33f25f2644edeedde7dbac3ba68e7f3dd7282 /configure.ac
parent61b99ab5c25609c11369733a0df97c03a0581a56 (diff)
downloadusbmuxd-56f013bd36652edb5034652dbf13719094dee45b.tar.gz
usbmuxd-56f013bd36652edb5034652dbf13719094dee45b.tar.bz2
autoconf: Fix processing of --with-preflight and --with-systemd options
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index baf98ca..e77a599 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,7 +28,7 @@ PKG_CHECK_MODULES(limd_glue, libimobiledevice-glue-1.0 >= 1.0.0)
AC_ARG_WITH([preflight],
[AS_HELP_STRING([--without-preflight],
[do not build with preflight worker support @<:@default=yes@:>@])],
- [with_preflight=no],
+ [with_preflight=$withval],
[with_preflight=yes])
if test "x$have_limd" = "xyes"; then
@@ -75,7 +75,7 @@ fi
AC_ARG_WITH([systemd],
[AS_HELP_STRING([--without-systemd],
[do not build with systemd support @<:@default=yes@:>@])],
- [],
+ [with_systemd=$withval],
[with_systemd=yes])
AC_ARG_WITH([systemdsystemunitdir],