summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Gavin Li2018-01-14 02:10:18 -0800
committerGravatar Nikias Bassen2018-01-31 01:08:58 +0100
commit7f54d304149f405dc70ac924471df0d5e3e5ea09 (patch)
tree86925888a0979eb4a67174142e9edb1bbbc1447a /configure.ac
parent27cbec8e00b2da5ac0514c76473d6d0b0164ab6f (diff)
downloadusbmuxd-7f54d304149f405dc70ac924471df0d5e3e5ea09.tar.gz
usbmuxd-7f54d304149f405dc70ac924471df0d5e3e5ea09.tar.bz2
udev: ensure that all events relating to device are tagged systemd
systemd will not restart the usbmuxd service the after the first time it is plugged in if it does not receive the "remove" events, which also happen to lack the idVendor and idProduct attributes, so use ENV{PRODUCT} instead.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b836f45..1ce46d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -74,7 +74,7 @@ fi
AM_CONDITIONAL(WANT_SYSTEMD, [test -n "$with_systemdsystemunitdir" -a "x$with_systemdsystemunitdir" != xno -a "x$with_systemd" = "xyes" ])
if test "x$with_systemd" = xyes; then
- udev_activation_rule="TAG+=\"systemd\", ENV{SYSTEMD_WANTS}=\"usbmuxd.service\""
+ udev_activation_rule="ENV{SYSTEMD_WANTS}=\"usbmuxd.service\""
else
udev_activation_rule="RUN+=\"@sbindir@/usbmuxd --user usbmux --udev\""
fi