summaryrefslogtreecommitdiffstats
path: root/libusbmuxd/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2010-05-24 18:57:10 +0200
committerGravatar Nikias Bassen2010-05-26 01:39:28 +0200
commit6cb505257ff848aa7ead80b60b575effc3a915fa (patch)
tree941978b9186158ea2775f50c5929f9e8b88764be /libusbmuxd/CMakeLists.txt
parent847eaeba69de3b22e5d65b3a98311655876df80e (diff)
downloadusbmuxd-6cb505257ff848aa7ead80b60b575effc3a915fa.tar.gz
usbmuxd-6cb505257ff848aa7ead80b60b575effc3a915fa.tar.bz2
Add protocol version 1 (plist based) support using libplist
Diffstat (limited to 'libusbmuxd/CMakeLists.txt')
-rw-r--r--libusbmuxd/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/libusbmuxd/CMakeLists.txt b/libusbmuxd/CMakeLists.txt
index d275169..236cca3 100644
--- a/libusbmuxd/CMakeLists.txt
+++ b/libusbmuxd/CMakeLists.txt
@@ -3,7 +3,11 @@ find_package(Threads)
add_library (libusbmuxd SHARED libusbmuxd.c sock_stuff.c ${CMAKE_SOURCE_DIR}/common/utils.c)
find_library (PTHREAD pthread)
-target_link_libraries (libusbmuxd ${CMAKE_THREAD_LIBS_INIT})
+
+if (HAVE_PLIST)
+ message("-- libusbmuxd will be built with protocol version 1 support")
+endif()
+target_link_libraries (libusbmuxd ${CMAKE_THREAD_LIBS_INIT} ${OPT_LIBS})
# 'lib' is a UNIXism, the proper CMake target is usbmuxd
# But we can't use that due to the conflict with the usbmuxd daemon,