summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d0c8201..fb59203 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,15 @@ if test "x$have_limd" = "xyes"; then
AC_DEFINE(HAVE_LIBIMOBILEDEVICE, 1, [Define if you have libimobiledevice support])
AC_SUBST(libimobiledevice_CFLAGS)
AC_SUBST(libimobiledevice_LIBS)
+ AC_CACHE_CHECK(for enum idevice_connection_type, ac_cv_enum_idevice_connection_type,
+ AC_TRY_COMPILE([
+ #include <libimobiledevice/libimobiledevice.h>
+ ], [
+ enum idevice_connection_type conn_type = CONNECTION_USBMUXD;
+ ], ac_cv_enum_idevice_connection_type=yes, ac_cv_enum_idevice_connection_type=no))
+ if (test "$ac_cv_enum_idevice_connection_type" = "yes"); then
+ AC_DEFINE(HAVE_ENUM_IDEVICE_CONNECTION_TYPE, 1, [Define if enum idevice_connection_type is available])
+ fi
fi
else
if test "x$with_preflight" == "xyes"; then