summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..8a96e46
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,32 @@
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)
+
+AM_CFLAGS = \
+ $(GLOBAL_CFLAGS) \
+ $(libplist_CFLAGS) \
+ $(libusb_CFLAGS) \
+ $(limd_glue_CFLAGS) \
+ $(libimobiledevice_CFLAGS)
+
+AM_LDFLAGS = \
+ $(libplist_LIBS) \
+ $(libusb_LIBS) \
+ $(limd_glue_LIBS) \
+ $(libimobiledevice_LIBS) \
+ $(libpthread_LIBS)
+
+sbin_PROGRAMS = usbmuxd
+
+usbmuxd_CFLAGS = $(AM_CFLAGS)
+usbmuxd_LDFLAGS = $(AM_LDFLAGS) -no-undefined
+usbmuxd_SOURCES = \
+ client.c client.h \
+ device.c device.h \
+ preflight.c preflight.h \
+ log.c log.h \
+ usbmuxd-proto.h \
+ usb.c usb.h \
+ utils.c utils.h \
+ conf.c conf.h \
+ main.c