summaryrefslogtreecommitdiffstats
path: root/usbmuxd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'usbmuxd/CMakeLists.txt')
-rw-r--r--usbmuxd/CMakeLists.txt9
1 files changed, 1 insertions, 8 deletions
diff --git a/usbmuxd/CMakeLists.txt b/usbmuxd/CMakeLists.txt
index 8d22ef6..b982dc0 100644
--- a/usbmuxd/CMakeLists.txt
+++ b/usbmuxd/CMakeLists.txt
@@ -1,16 +1,9 @@
-PROJECT(usbmuxd)
-
-cmake_minimum_required(VERSION 2.6)
-
-set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_SOURCE_DIR}/Modules/")
-
find_package(USB REQUIRED)
include_directories(${USB_INCLUDE_DIRS})
set(LIBS ${LIBS} ${USB_LIBRARIES})
-#set(CMAKE_VERBOSE_MAKEFILE ON)
-
add_definitions(-Wall -O2 -g)
add_executable(usbmuxd main.c usb-linux.c log.c utils.c device.c client.c)
target_link_libraries(usbmuxd ${LIBS})
+install(TARGETS usbmuxd RUNTIME DESTINATION sbin) \ No newline at end of file