summaryrefslogtreecommitdiffstats
path: root/axiom/test/xpath/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'axiom/test/xpath/Makefile.am')
-rw-r--r--axiom/test/xpath/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/axiom/test/xpath/Makefile.am b/axiom/test/xpath/Makefile.am
new file mode 100644
index 0000000..ed70ed6
--- /dev/null
+++ b/axiom/test/xpath/Makefile.am
@@ -0,0 +1,20 @@
+TESTS =
+noinst_PROGRAMS = test_xpath test_xpath_streaming
+check_PROGRAMS = test_xpath test_xpath_streaming
+SUBDIRS =
+test_xpath_SOURCES = test_xpath.c
+
+test_xpath_streaming_SOURCES = test_xpath_streaming.c
+
+test_xpath_LDADD = ../../../util/src/libaxutil.la \
+ $(top_builddir)/src/om/libaxis2_axiom.la \
+ $(top_builddir)/src/xpath/libaxis2_xpath.la
+
+test_xpath_streaming_LDADD = ../../../util/src/libaxutil.la \
+ $(top_builddir)/src/om/libaxis2_axiom.la \
+ $(top_builddir)/src/xpath/libaxis2_xpath.la
+
+INCLUDES = -I$(top_builddir)/include \
+ -I$(top_builddir)/src/parser \
+ -I ../../../include \
+ -I ../../../util/include