summaryrefslogtreecommitdiffstats
path: root/samples/server/sg_math/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'samples/server/sg_math/Makefile.am')
-rw-r--r--samples/server/sg_math/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/samples/server/sg_math/Makefile.am b/samples/server/sg_math/Makefile.am
new file mode 100644
index 0000000..82cc1ba
--- /dev/null
+++ b/samples/server/sg_math/Makefile.am
@@ -0,0 +1,11 @@
+prglibdir=$(prefix)/services/sg_math
+prglib_LTLIBRARIES = libadd.la libsub.la libmul.la libdiv.la
+prglib_DATA=services.xml
+EXTRA_DIST = services.xml sg_math.mk add.h div.h mul.h sub.h
+
+noinst_HEADERS = add.h sub.h mul.h div.h
+libadd_la_SOURCES = add.c add_skeleton.c
+libsub_la_SOURCES = sub.c sub_skeleton.c
+libmul_la_SOURCES = mul.c mul_skeleton.c
+libdiv_la_SOURCES = div.c div_skeleton.c
+INCLUDES = @AXIS2INC@