summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar mszulecki2007-02-26 02:28:05 +0000
committerGravatar mszulecki2007-02-26 02:28:05 +0000
commit09f526cd1dc150b10db6439d2f1dbb0d3107060c (patch)
tree0ce421c2f8555463e4ff97518ef07274046d4625 /configure.ac
parentde41ac9f6d7d3ee046719d69adf504b02ead30a2 (diff)
downloaddskel-09f526cd1dc150b10db6439d2f1dbb0d3107060c.tar.gz
dskel-09f526cd1dc150b10db6439d2f1dbb0d3107060c.tar.bz2
Add gdc version to config.d and show it in helloworld.
git-svn-id: http://svn.sukimashita.com/repos/dskel/trunk@17 4281df72-ff29-0410-8fee-2d9ac0c5f5a7
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c2e6daa..396ca93 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,7 @@ if test "x$GDC" = "xno"; then
fi
AC_SUBST(GDC)
+AC_SUBST(GDC_VERSION,[$($GDC --version | grep -P -o "(?<=\()gdc (.*?)(?=,)")])
AC_SUBST(DFLAGS, "-g -O2")
dnl TODO: Check for Phobos Library
@@ -50,5 +51,5 @@ echo ""
echo "Configuration summary"
echo ""
echo " * Installation prefix = $prefix"
-echo " * D compiler: $GDC"
+echo " * D compiler: $GDC_VERSION - $GDC"
echo ""