summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index c2e6daa..396ca93 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,7 @@ if test "x$GDC" = "xno"; then
fi
AC_SUBST(GDC)
+AC_SUBST(GDC_VERSION,[$($GDC --version | grep -P -o "(?<=\()gdc (.*?)(?=,)")])
AC_SUBST(DFLAGS, "-g -O2")
dnl TODO: Check for Phobos Library
@@ -50,5 +51,5 @@ echo ""
echo "Configuration summary"
echo ""
echo " * Installation prefix = $prefix"
-echo " * D compiler: $GDC"
+echo " * D compiler: $GDC_VERSION - $GDC"
echo ""