summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorGravatar mszulecki2007-06-11 23:21:52 +0000
committerGravatar mszulecki2007-06-11 23:21:52 +0000
commit588a4b204ba7d0c91b7a36acc834de5750608825 (patch)
tree6da2f70c049248c347200b5c5879030088288d8c /doc/Makefile.am
parent4319df5e65fd6c1c8a3aee369773db4add185093 (diff)
downloaddskel-588a4b204ba7d0c91b7a36acc834de5750608825.tar.gz
dskel-588a4b204ba7d0c91b7a36acc834de5750608825.tar.bz2
Add basic HTML documentation generation and installation.
git-svn-id: http://svn.sukimashita.com/repos/dskel/trunk@27 4281df72-ff29-0410-8fee-2d9ac0c5f5a7
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..d42603b
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,22 @@
+TARGET_DIR=$(docdir)
+
+clean-local:
+ cd $(top_srcdir) && rm -rf doc/*.html
+
+install-data-local:
+ installfiles=`echo $(top_srcdir)/doc/*.html`; \
+ if test "$$installfiles" = '$(top_srcdir)/doc/*.html'; \
+ then echo '-- Nothing to install' ; \
+ else \
+ $(mkinstalldirs) $(DESTDIR)$(TARGET_DIR); \
+ for i in $$installfiles; do \
+ echo '-- Installing '$$i ; \
+ $(INSTALL_DATA) $$i $(DESTDIR)$(TARGET_DIR); \
+ done; \
+ fi
+
+uninstall-local:
+ rm -rf $(DESTDIR)$(TARGET_DIR)
+
+DISTCLEANFILES = \
+ Makefile.in