summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGravatar mszulecki2007-02-21 17:18:01 +0000
committerGravatar mszulecki2007-02-21 17:18:01 +0000
commitbab430316c0c5b88a59c1145a92c55bb55c7da11 (patch)
tree50b07e4dea9bc023b2cf0f91775c4cac9eac0362 /src/Makefile.am
parent83283f521dd59e3f5a4c4dda3ae61a6db4406684 (diff)
downloaddskel-bab430316c0c5b88a59c1145a92c55bb55c7da11.tar.gz
dskel-bab430316c0c5b88a59c1145a92c55bb55c7da11.tar.bz2
First attempt at an autotools D helloworld.
git-svn-id: http://svn.sukimashita.com/repos/dskel/trunk@2 4281df72-ff29-0410-8fee-2d9ac0c5f5a7
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..520df7e
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,11 @@
+SUFFIXES= .d
+
+.d.o:
+ $(GDC) $(DFLAGS) -c -o $@ $<
+
+bin_PROGRAMS = helloworld
+
+helloworld_SOURCES = helloworld.d
+helloworld_LDADD = $(DEPS_LIBS)
+
+AM_CPPFLAGS = $(DEPS_CFLAGS)