summaryrefslogtreecommitdiffstats
path: root/tools/Makefile.am
diff options
context:
space:
mode:
authorGravatar Martin Szulecki2014-03-04 22:55:41 +0100
committerGravatar Martin Szulecki2014-03-04 22:55:41 +0100
commit5838f6d67a46370d82dd2f19588c06562c9fe0de (patch)
tree2c767d51bfbc8082243ad84a291f454382b79298 /tools/Makefile.am
parentb574a78a99577e88419b8dfe67f863d15ebbcd79 (diff)
downloadlibimobiledevice-5838f6d67a46370d82dd2f19588c06562c9fe0de.tar.gz
libimobiledevice-5838f6d67a46370d82dd2f19588c06562c9fe0de.tar.bz2
Add new "idevicecrashreport" tool to retrieve crash reports/logs from a device
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index c280715..6184fcd 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -74,3 +74,11 @@ idevicediagnostics_SOURCES = idevicediagnostics.c
idevicediagnostics_CFLAGS = $(AM_CFLAGS)
idevicediagnostics_LDFLAGS = $(AM_LDFLAGS)
idevicediagnostics_LDADD = ../src/libimobiledevice.la
+
+if !WIN32
+bin_PROGRAMS += idevicecrashreport
+idevicecrashreport_SOURCES = idevicecrashreport.c
+idevicecrashreport_CFLAGS = $(AM_CFLAGS)
+idevicecrashreport_LDFLAGS = $(top_srcdir)/common/libinternalcommon.la $(AM_LDFLAGS)
+idevicecrashreport_LDADD = ../src/libimobiledevice.la
+endif