summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2023-04-24 14:16:31 +0200
committerGravatar Nikias Bassen2023-04-24 14:16:31 +0200
commit5d65599261515b6af769b580d83c3d39d85ea2ac (patch)
tree8101f9114af877506dfba2637af2a9bb4c34876b /Makefile.am
parent61f01b1b06ff906cce4c4c3b2aa031f2efaf1201 (diff)
downloadlibplist-5d65599261515b6af769b580d83c3d39d85ea2ac.tar.gz
libplist-5d65599261515b6af769b580d83c3d39d85ea2ac.tar.bz2
autoconf: Allow disabling build of test suite
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 84b196d..7da967d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,15 @@
AUTOMAKE_OPTIONS = foreign
ACLOCAL_AMFLAGS = -I m4
-SUBDIRS = libcnary src include tools test docs
+SUBDIRS = libcnary src include tools docs
if HAVE_CYTHON
SUBDIRS += cython
endif
+if BUILD_TESTS
+SUBDIRS += test
+endif
+
if BUILD_FUZZERS
SUBDIRS += fuzz
endif