summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2024-01-29 17:15:26 +0100
committerGravatar Nikias Bassen2024-01-29 17:15:26 +0100
commit07cd6f774fd444f981ade6e75e10962ba0439350 (patch)
tree7fc0582e24809b022c7752a5f217f9a5a0f3d567 /configure.ac
parent2d8784187c1eb25bdac7a57015fe18dcc9eff4ab (diff)
downloadlibusbmuxd-07cd6f774fd444f981ade6e75e10962ba0439350.tar.gz
libusbmuxd-07cd6f774fd444f981ade6e75e10962ba0439350.tar.bz2
Move USBMUXD_API to public headers
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 9d5eddb..36df4b4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -117,14 +117,14 @@ AM_CONDITIONAL(WIN32, test x$win32 = xtrue)
AS_COMPILER_FLAGS(GLOBAL_CFLAGS, "-Wall -Wextra -Wmissing-declarations -Wredundant-decls -Wshadow -Wpointer-arith -Wwrite-strings -Wswitch-default -Wno-unused-parameter -fvisibility=hidden $PTHREAD_CFLAGS")
GLOBAL_LDFLAGS="$PTHREAD_LIBS"
+
+if test "x$enable_static" = "xyes" -a "x$enable_shared" = "xno"; then
+ GLOBAL_CFLAGS+=" -DLIBUSBMUXD_STATIC"
+fi
+
AC_SUBST(GLOBAL_CFLAGS)
AC_SUBST(GLOBAL_LDFLAGS)
-case "$GLOBAL_CFLAGS" in
- *-fvisibility=hidden*)
- AC_DEFINE([HAVE_FVISIBILITY], [1], [Define if compiled with -fvisibility=hidden])
-esac
-
m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
AC_CONFIG_FILES([