summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2013-12-13 11:32:25 +0100
committerGravatar Nikias Bassen2013-12-13 11:32:25 +0100
commitb867ce936b1aab79a77e7a8a0fab5afaab872e47 (patch)
tree16dd66afea62f989f3b3e6ef5a9dfece1463e059 /configure.ac
parent01cb5daf51612f9b949cd9643a584e7da6ff8c98 (diff)
downloadlibusbmuxd-b867ce936b1aab79a77e7a8a0fab5afaab872e47.tar.gz
libusbmuxd-b867ce936b1aab79a77e7a8a0fab5afaab872e47.tar.bz2
make libplist dependency/protov1 support mandatory
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 1 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index b730ebf..e259eb3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,30 +26,9 @@ AM_PROG_CC_C_O
AC_PROG_LIBTOOL
# Checks for libraries.
-PKG_CHECK_MODULES(libplist, libplist >= 1.9, have_plist=yes, have_plist=no)
+PKG_CHECK_MODULES(libplist, libplist >= 1.11)
AC_CHECK_HEADERS([sys/inotify.h], have_inotify=yes, have_inotify=no)
-AC_ARG_WITH([protov1],
- [AS_HELP_STRING([--without-protov1],
- [do not build with protocol v1 support (default is yes)])],
- [with_protov1=no],
- [with_protov1=yes])
-
-if test "x$have_plist" = "xyes"; then
- if test "x$with_protov1" != "xyes"; then
- have_plist=no
- echo "*** Note: Protocol V1 support has been disabled ***"
- else
- AC_DEFINE(HAVE_PLIST, 1, [Define if you have libplist support])
- AC_SUBST(libplist_CFLAGS)
- AC_SUBST(libplist_LIBS)
- fi
-else
- if test "x$with_protov1" == "xyes"; then
- AC_MSG_ERROR([protocol V1 support requested but libplist could not be found])
- fi
-fi
-
AC_ARG_WITH([inotify],
[AS_HELP_STRING([--without-inotify],
[(Linux only) do not build with inotify support (default is yes)])],
@@ -120,7 +99,6 @@ Configuration for $PACKAGE $VERSION:
-------------------------------------------
Install prefix: .........: $prefix
- Protocol v1 support: ....: $have_plist
inotify support (Linux) .: $have_inotify
Now type 'make' to build $PACKAGE $VERSION,