summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2013-09-17 11:00:31 +0200
committerGravatar Nikias Bassen2013-09-17 11:00:31 +0200
commitc45ae1f6b6f53995a5bc99591688102d11ad2148 (patch)
tree03e36986e4ad61f6345c64b7b2f673eebee33816 /configure.ac
downloadlibusbmuxd-c45ae1f6b6f53995a5bc99591688102d11ad2148.tar.gz
libusbmuxd-c45ae1f6b6f53995a5bc99591688102d11ad2148.tar.bz2
initial commit of adapted source tree.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac124
1 files changed, 124 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..6948d18
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,124 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.61)
+AC_INIT(libusbmuxd, 1.0.8, nospam@nowhere.com)
+AM_INIT_AUTOMAKE([dist-bzip2 no-dist-gzip])
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES])
+AC_CONFIG_SRCDIR([src/])
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_MACRO_DIR([m4])
+
+dnl libtool versioning
+# +1 : 0 : +1 == adds new functions to the interface
+# +1 : 0 : 0 == changes or removes functions (changes include both
+# changes to the signature and the semantic)
+# ? :+1 : ? == just internal changes
+# CURRENT : REVISION : AGE
+LIBUSBMUXD_SO_VERSION=2:0:0
+
+AC_SUBST(LIBUSBMUXD_SO_VERSION)
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_CXX
+AM_PROG_CC_C_O
+AC_PROG_LIBTOOL
+
+# Checks for libraries.
+PKG_CHECK_MODULES(libplist, libplist >= 1.9, have_plist=yes, have_plist=no)
+AC_CHECK_HEADERS([sys/inotify.h], have_inotify=yes, have_inotify=no)
+
+AC_ARG_WITH([protov1],
+ [AS_HELP_STRING([--without-protov1],
+ [do not build with protocol v1 support (default is yes)])],
+ [with_protov1=no],
+ [with_protov1=yes])
+
+if test "x$have_plist" = "xyes"; then
+ if test "x$with_protov1" != "xyes"; then
+ have_plist=no
+ echo "*** Note: Protocol V1 support has been disabled ***"
+ else
+ AC_DEFINE(HAVE_PLIST, 1, [Define if you have libplist support])
+ AC_SUBST(libplist_CFLAGS)
+ AC_SUBST(libplist_LIBS)
+ fi
+else
+ if test "x$with_protov1" == "xyes"; then
+ AC_MSG_ERROR([protocol V1 support requested but libplist could not be found])
+ fi
+fi
+
+AC_ARG_WITH([inotify],
+ [AS_HELP_STRING([--without-inotify],
+ [(Linux only) do not build with inotify support (default is yes)])],
+ [with_inotify=no],
+ [with_inotify=yes])
+
+if test "x$have_inotify" = "xyes"; then
+ if test "x$with_inotify" != "xyes"; then
+ have_inotify=no
+ echo "*** Note: inotify support has been disabled ***"
+ else
+ AC_DEFINE(HAVE_INOTIFY, 1, [Define if you have inotify support (linux only)])
+ fi
+fi
+
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([stdint.h stdlib.h string.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_SIZE_T
+AC_TYPE_SSIZE_T
+AC_TYPE_UINT16_T
+AC_TYPE_UINT32_T
+AC_TYPE_UINT8_T
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+AC_CHECK_FUNCS([strcasecmp strdup strerror strndup])
+
+# Check for operating system
+AC_MSG_CHECKING([whether to enable WIN32 build settings])
+case ${host_os} in
+ *mingw32*|*cygwin*)
+ win32=true
+ AC_MSG_RESULT([yes])
+ AC_CHECK_TOOL([WINDRES], [windres], AC_MSG_ERROR([windres not found]))
+ AC_SUBST(WINDRES)
+ ;;
+ *)
+ win32=false
+ AC_MSG_RESULT([no])
+ ;;
+esac
+AM_CONDITIONAL(WIN32, test x$win32 = xtrue)
+
+AS_COMPILER_FLAGS(GLOBAL_CFLAGS, "-Wall -Wextra -Wmissing-declarations -Wredundant-decls -Wshadow -Wpointer-arith -Wwrite-strings -Wswitch-default -Wno-unused-parameter")
+AC_SUBST(GLOBAL_CFLAGS)
+
+m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
+
+AC_OUTPUT([
+Makefile
+src/Makefile
+include/Makefile
+tools/Makefile
+libusbmuxd.pc
+])
+
+echo "
+Configuration for $PACKAGE $VERSION:
+-------------------------------------------
+
+ Install prefix: .........: $prefix
+ Protocol v1 support: ....: $have_plist
+ inotify support (Linux) .: $have_inotify
+
+ Now type 'make' to build $PACKAGE $VERSION,
+ and then 'make install' for installation.
+"