summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2018-10-13 04:23:20 +0200
committerGravatar Nikias Bassen2018-10-13 04:23:20 +0200
commitf5a7387a54ae08c9cd1d83a415393e0e909dc6e6 (patch)
tree65a088de3e04da331c0dc726d32621a35c68406f /configure.ac
parentd942a73b6fca6388ff8085e8f58790bf15b962a1 (diff)
downloadlibusbmuxd-f5a7387a54ae08c9cd1d83a415393e0e909dc6e6.tar.gz
libusbmuxd-f5a7387a54ae08c9cd1d83a415393e0e909dc6e6.tar.bz2
Add proper support for USB and network (WiFi sync) devices reported by usbmuxd
This commit extends the interface with a new function usbmuxd_get_device() that allows to look up USB *and* network devices, while the 'old' interface usbmuxd_get_device_by_udid() only targets USB devices. The usbmuxd_device_info_t structure now has new members 'conn_type' and 'conn_data' so that the returned device info allows to figure out if a device is available via USB or network. Check the comments in include/usbmuxd.h for more details.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b719b96..ab056b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -66,7 +66,7 @@ AC_TYPE_UINT8_T
# Checks for library functions.
AC_FUNC_MALLOC
AC_FUNC_REALLOC
-AC_CHECK_FUNCS([strcasecmp strdup strerror strndup sleep])
+AC_CHECK_FUNCS([strcasecmp strdup strerror stpncpy sleep])
# Check for operating system
AC_MSG_CHECKING([whether we need platform-specific build settings])