summaryrefslogtreecommitdiffstats
path: root/libusbmuxd/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Hector Martin2009-08-20 03:42:52 +0200
committerGravatar Hector Martin2009-08-20 06:51:10 +0200
commit1a0c58e4062da7db73b4c08963f741cf016f6aa5 (patch)
treeb250f094e978d48622ecf652e28e9f3b68873893 /libusbmuxd/CMakeLists.txt
parentf4854f3fd725b5ba49cd5157d941783cffa08c04 (diff)
parent79ca4d9a3c3a82bb5a3f9be1ac7a2533c7a89b05 (diff)
downloadusbmuxd-1a0c58e4062da7db73b4c08963f741cf016f6aa5.tar.gz
usbmuxd-1a0c58e4062da7db73b4c08963f741cf016f6aa5.tar.bz2
Merge the two development histories
Diffstat (limited to 'libusbmuxd/CMakeLists.txt')
-rw-r--r--libusbmuxd/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/libusbmuxd/CMakeLists.txt b/libusbmuxd/CMakeLists.txt
new file mode 100644
index 0000000..61de1a8
--- /dev/null
+++ b/libusbmuxd/CMakeLists.txt
@@ -0,0 +1,12 @@
+add_library (libusbmuxd libusbmuxd.c sock_stuff.c)
+
+# 'lib' is a UNIXism, the proper CMake target is usbmuxd
+# But we can't use that due to the conflict with the usbmuxd daemon,
+# so instead change the library output base name to usbmuxd here
+set_target_properties(libusbmuxd PROPERTIES OUTPUT_NAME usbmuxd)
+
+install(TARGETS libusbmuxd
+ ARCHIVE DESTINATION lib
+ LIBRARY DESTINATION lib
+)
+install(FILES usbmuxd.h usbmuxd-proto.h DESTINATION include)