summaryrefslogtreecommitdiffstats
path: root/libusbmuxd/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libusbmuxd/CMakeLists.txt')
-rw-r--r--libusbmuxd/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/libusbmuxd/CMakeLists.txt b/libusbmuxd/CMakeLists.txt
new file mode 100644
index 0000000..61de1a8
--- /dev/null
+++ b/libusbmuxd/CMakeLists.txt
@@ -0,0 +1,12 @@
+add_library (libusbmuxd libusbmuxd.c sock_stuff.c)
+
+# 'lib' is a UNIXism, the proper CMake target is usbmuxd
+# But we can't use that due to the conflict with the usbmuxd daemon,
+# so instead change the library output base name to usbmuxd here
+set_target_properties(libusbmuxd PROPERTIES OUTPUT_NAME usbmuxd)
+
+install(TARGETS libusbmuxd
+ ARCHIVE DESTINATION lib
+ LIBRARY DESTINATION lib
+)
+install(FILES usbmuxd.h usbmuxd-proto.h DESTINATION include)