summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGravatar Nikias Bassen2013-09-17 12:06:05 +0200
committerGravatar Nikias Bassen2013-09-17 12:06:05 +0200
commit48e18c703071170af8f0723ab24426eec0a39251 (patch)
tree41f9cf7b7021ce2f7480cd5318e756c9bb4b9b42 /configure.ac
parentc45ae1f6b6f53995a5bc99591688102d11ad2148 (diff)
downloadlibusbmuxd-48e18c703071170af8f0723ab24426eec0a39251.tar.gz
libusbmuxd-48e18c703071170af8f0723ab24426eec0a39251.tar.bz2
added libpthread_LIBS to fix build in tools
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6948d18..8cbe7a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,6 +98,10 @@ case ${host_os} in
esac
AM_CONDITIONAL(WIN32, test x$win32 = xtrue)
+if test "x$win32" != "xtrue"; then
+ AC_CHECK_LIB(pthread, [pthread_create, pthread_mutex_lock], [AC_SUBST(libpthread_LIBS,[-lpthread])], [AC_MSG_ERROR([libpthread is required to build libusbmuxd])])
+fi
+
AS_COMPILER_FLAGS(GLOBAL_CFLAGS, "-Wall -Wextra -Wmissing-declarations -Wredundant-decls -Wshadow -Wpointer-arith -Wwrite-strings -Wswitch-default -Wno-unused-parameter")
AC_SUBST(GLOBAL_CFLAGS)